Windows 2012 2016 无法安装 .NET 3.5 4.6-Sleep's Blog

关注每一天新的互联网!

Windows 2012 2016 无法安装 .NET 3.5 4.6

ECS _ Error _ 安装 .NET Framework

解决办法

您可以使用如下 PowerShell 脚本进行安装。

  1. 从 开始 菜单中找到 PowerShell,右键单击选择 以管理员身份运行。
  2. 输入如下脚本后,按回车键执行。
    
    
    1. Set-ItemProperty -Path 'HKLM:\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU' -Name UseWUServer -Value 0
    2. Restart-Service -Name wuauserv
    3. Install-WindowsFeature Net-Framework-Core
    4. Set-ItemProperty -Path 'HKLM:\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU' -Name UseWUServer -Value 1
    5. Restart-Service -Name wuauserv

如果依然报错,请在服务器中开启windows update服务,再执行一次,然后继续安装IIS或者其他服务。

分享到:更多 ()

评论 1

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
  1. #1

    到你的博客走一趟,如同阳光洒在我脸上,心里暖洋洋!

    罗拉套图网3周前 (08-02)